I was playing on a public server, I was driving an offroad when I lost connection. Since then, when I try to join any server that could load my saved character, I just get a black screen (I still have options and all, except I cant respawn : I get kicked by servers when I try).

Also, first thing I normally see is a button on bottom left corner of screen, I think it’s about chat / voice. This doesnt even show up. No message no nothing, just black screen.

Anyone knows what I should do ? Im ready to respawn and loose all my stuff, but i’m not allowed to…

Any help, please ?


  • Profile photo of Le Marcheur

    Little update : this is happening with all servers after some time.

    I join a server, I play some time (lets say between like 10 mins and 1 hour or something), and I loose session. I join the server again. I’ll loose connection again. At some point, if I try again to join server, I get a black screen. Ill be able to join server again around 24 hours after.

    In the mean time, as I cant stick to a single server, I cant even set up some camp… No point to search for a car also and such. In fact, impossible to enjoy the Dayz experience in those conditions.

    Did this happen to anyone else ? Ive tried everything I could find on internet, nothing worked yet…

    • Profile photo of Deadjuice

      I had a similar issues before, here’s my analysis. I like type, skip to bottom for TLDR.

      Was playing with my two brothers. We geared up together on a low pop server, and then attempted to join a high pop server [Inferno in Cherno].
      We where trying to spawn in Electro, down on the small island/peninsula south of the industrial area.We knew Electro would have a decent amount of activity with players in it PVPing. so a notable amount of server strain.

      •Brother 3 got in with little problem.

      •I spawned in, but the game would never finish loading/rendering. I would be stuck at 1 FPS, barely able to move, and would eventually time out. I tried about 6-10 times to get in.

      •Brother 2 had the black screen problem. Menu loaded, then black screen. he tried 6-10 like me. He would be at black black screen, and I or Brother 3 would see that he timed out in global message.

      After my dozenth attempt, I moved my guy in the 1 FPS drag a considerable distance [10ft], and the game started working normally. When me and Brother 3 moved into town farther, Brother 2 was finally able to spawn in.

      We had a similar situation several month before.
      [ https://youtu.be/cvvkrzrf4vY?t=3m50s video for reference if interested]
      Got into a gunfight in Electro, industrial area next to tracks. I went unconscious. Brother 3 covered Brother 2 as he tried to revive me.
      Brother 2 suddenly gets memory error and has to restart game. I regain consciousness.
      There are a few player bodies, tons of zombie bodies, and a constant rain of bambies trying to rush us for our gear.
      We try to stay in the area, so as to cover Brother 2 when he logs in, but he is unable to. He tries a dozen times, timing out each time. We finally think to try move away from his spawn location. We went not too far into town more, and he spawns in, no problem.

      In conclusion/TL,DR:
      The problem seems to be spawning into highly populated areas, especially cities, with other players in close proximity.
      Either spawn in a low pop server and move away from the area, or blindly wait for the area do become depopulated.

      • Profile photo of Le Marcheur

        Hey, yea I see what you mean, but its happening constantly. If I loose session 2 times, it’s over, next time I wont be in, where ever I am (I am usually in middle of nowhere as I tend to avoid cities…). Cant be a question of population or stuff spawned around me. Most of the time there are only trees where I am 🙂

  • Profile photo of newt

    Delete your profile saved under C drive. Win 10 I think it is under C/Users/Your PC name/ Documents/DayZ and then also maybe just verify your games integrity through steam. Look how to up on Youtube as there are many help videos. Right click game/Properties/Local Files/ Verify the integrity of Game Cache or something close to that though

    • Profile photo of Le Marcheur

      Hi, thanks 🙂 well as far as I see, it looks like punishment for server hopping. Not that I do server hopping to loot things or kill people, I just had so many problems in terms of internet connection that I am loosing sessions so so so many times. I am able to log on some other servers, but not the 2 ones where I have a little base. If I wait until like tomorrow ill be able to play again on that server I think… But hell, I get punished because my internet connection is bad it seems 🙁

  • Profile photo of Le Marcheur

    Ok apparently I solved the problem. Here are the things I did, if this help anyone

    – Delete clientregistry.blob file from steam folder
    – Clear steam download cache
    – dont use a VPN

    Problem solved 🙂