Hey guys…I just bought another DayZ for my brother…WE tried to connect but the problem is I can join with no problem but when my brother is trying to join we both get disconnected…The wierd thing is that’s not happen every time at that point…I mean some times we can play for 10 minutes some times for 30 minutes but finally we both get kicked…I dunno why…Can I do something…Can any body plz help us??I have read somewhere that is because of single Ip address but we can play BF4 just fine…I’m not sure what is wrong here…Please help us solve this…


*


  • Profile photo of Ulenran

    Some DayZ server providers will block more than one IP coming from the same address, so this might be your problem. I can’t rememnber how I fixed mine, but I just searched online until I found a forum post with the solution. If I remember what it was I did, I will post back here.

    0
  • Profile photo of HomeStoned

    did you sort it out?
    here’s 2 possible solutions, 1st simplest…2nd not ideal:
    1st:
    Do this on ONE Pc
    Open steam then go library, right click DayZ, go properties, launch options then add this “-port=2350” without quotation marks in your DayZ Startup Parameters.
    Strange thing is that it won’t actually use the port you specify, in this case 2350, it’ll use +2, +3 of that. So you could technically specify -port=2304 and it’ll end up using 2306, 2307.

    2nd:
    Its probably a security thing. In some routers, there are different types of NAT. I will have to test and see if I can get around it. Another option (while expensive) is to get a block of static ip addresses from your provider so that each person’s computer has a different public ip address. This would definately work.
    Login to your routers config page
    Look for something that pertains to NAT. It depends on the router, some call it strict nat, you want that disabled. On mine its “restrict forwarding rules to ip” and I have it turned off. The issue is that you want to make sure the traffic does not go to one pc or the other. This is why upnp has to be turned off. UPNP is actually setting up forwarding rules automatically to one machine or the other..You should not have to forward any ports to your machines, and if you do, the forwarding rules are taking all that inbound traffic and sending it to one machine. Also, dont DMZ just one machine, because you are in effect doing the same thing.

    0
  • Profile photo of HomeStoned

    TRY THIS FIRST
    In each computer you do this.
    • Go into Steam and open your Game Library
    • Right click in DayZ
    • Go to “Properties”
    • In the General tab, click on “SET LAUNCH OPTIONS…”
    • Now add a diferent port number in each PC writing this:
    +clientport 270XX
    Where: xx is a number betwen 05 and 32, but dont use 20

    Example:
    In PC 1: +clientport 27010
    In PC 2: +clientport 27015

    • Click on Ok

    0